IRCNow

You can run any Linux or BSD-based operating system on your VPS as a guest inside OpenBSD.

You will be given a username and password for your account. This will create a username on our host system:

$ ssh username@us5.ircnow.org

ECDSA key fingerprint is SHA256:a0LIR/BRZkpYqMho/YvkISPEm7vkus5QfOSqAeu+tYc.

Please note: This is the host machine, not your VM. The host machine is running OpenBSD but your guest VPS can run any OS.

Once you log in, you can access the serial console:

$ vmctl console <vm-name>

To shutdown the VM:

$ vmctl stop <vm-name>

To boot the VM:

$ vmctl start <vm-name>

To pause the VM:

$ vmctl pause <vm-name>

To unpause the VM:

$ vmctl unpause <vm-name>

To escape serial console, type ~~.


To connect to your VM, you will be given an IP address. In case you forget, your IP address can be found by running $ dig username.us5.ircnow.org. Our default gateway is 38.81.163.129.

For convenience, you can log in to your VPS as follows:

$ ssh username@username.us5.ircnow.org

Please note that this hostname is different from the host; there is an extra username in username.us5.ircnow.org.


To reinstall OpenBSD 6.6:

$ ssh username@us5.ircnow.org
$ cd ~
$ rm username.qcow2
$ vmctl create -s 20G username.qcow2
$ vmctl start username
$ vmctl start username
$ vmctl console username

Make sure to configure static networking as well as to set up ping in the background as outlined below.


For OpenBSD, here is how you statically assign your IP address:

Inside /etc/hostname.vio0:

inet 38.81.163.xxx 255.255.255.0

Replace 38.81.163.xxx with your assigned IP address.

Inside /etc/mygate:

38.81.163.129

For Alpine:

To restart networking:

# service networking restart

For Debian:

systemctl restart networking

Inside /etc/network/interfaces:

source /etc/network/interfaces.d/*

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
auto enp0s2
iface enp0s2 inet static
        address 38.81.163.x
        netmask 255.255.255.0
        gateway 38.81.163.129

Losing network connectivity:

For OpenBSD, put this in your crontab:

@reboot /usr/bin/tmux new -d 'while true; do /sbin/ping -i5 38.81.163.129; done' \;

Afterwards, to ensure it runs right away, execute this once:

/usr/bin/tmux new -d 'while true; do /sbin/ping -i5 38.81.163.129; done' \;

For Debian:

@reboot /usr/bin/tmux new -d 'while true; do /usr/bin/ping -i5 38.81.163.129; done' \;

Afterwards, to ensure it runs right away, execute this once:

/usr/bin/tmux new -d 'while true; do /usr/bin/ping -i5 38.81.163.129; 

For Alpine:

@reboot /usr/bin/tmux new -d 'while true; do /bin/ping -i5 38.81.163.129; done' \;

Afterwards, to ensure it runs right away, execute this once:

/usr/bin/tmux new -d 'while true; do /bin/ping -i5 38.81.163.129; done' \;

To reinstall OpenBSD:

First, log in to the host:

$ ssh username@us5.ircnow.org
$ vmctl stop username
$ rm username.qcow2
$ vmctl create -s 20G username.qcow2
$ vmctl start username
$ vmctl console username

Then, do the installation as usual.